
Coustyx Tutorial – Multidomain Model

1 Introduction

This tutorial is created to outline the steps required to compute radiated noise from a gearbox
housing using Coustyx software. Detailed steps are given on how to create a Coustyx ‘Multidomain
Model’ and perform the acoustic analysis.

1.1 General Procedure

Follow the procedure outlined below for general noise radiation prediction using Coustyx software.
The two steps involved in the prediction of noise radiated by a gearbox housing are: (a) determination
of housing vibration by experiments or analysis, here we do finite element analysis using ANSYS;
(b) prediction of radiated noise based on the vibration using Coustyx (boundary element method).

FEA The Finite Element Analysis (FEA) is used to build the mesh and to estimate the structural
vibration, which is used as the input velocity for acoustic analysis in Coustyx.

1. Build a finite element model of the gearbox housing from the geometry. Compute mode
shapes and natural frequencies of the structure from FEA modal analysis.

2. Estimate the forces transmitted to the gearbox housing through bearings or from other
interactions with the components in a gearbox. Transform the forces into the frequency
domain to obtain force amplitudes as a function of frequency.

3. Compute the housing structural response at each frequency of analysis using ANSYS.
Here the frequency response is computed by full (direct) harmonic analysis. The results
are stored in *.rst file.

Coustyx Acoustic radiation problem is then solved using Coustyx by importing the FEA structure
mesh and loading the structural response for the gearbox from the ANSYS results (*.rst) file.

1. Build a new Coustyx model by importing the FEA structure mesh.

2. Load the frequency response data from the FEA analysis into the Coustyx model. This
response is used as the velocity boundary condition for the acoustic analysis.

3. Set the Coustyx analysis parameters and run acoustic analysis to compute acoustic metrics
such as radiated sound power, radiation efficiency, pressure levels at field points, etc., at
each frequency.

1.2 Problem Description

The example gearbox housing analyzed in this tutorial is from a gear noise test rig developed at
NASA Lewis Research Center [1]. The details of the gear box are shown in Figure 1.
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Figure 1: Details of the GearBox analyzed.

The structure is a rectangular box of overall dimensions 0.2794 m x 0.3048 m x 0.29845 m, or 11
inches x 12 inches x 11.75 inches. The top plate is made of 1.588 mm or 1/16-inch aluminum and
the other five surfaces are made of 12.7 mm or 1/2-inch thick steel. Note that all the dimensions
considered in this tutorial are in S.I units. The four corners of the bottom surface are clamped
rigidly to the ground. The housing supports two shafts through bearings, which are mounted on the
four holes in the structure.
A shaker is attached to the center of the top plate to excite the system. A sinusoidal force of
unit amplitude is applied normal to the top plate. The noise radiation from the resulting gear box
vibration is computed in the frequency range 114.75–1000 Hz.

2 Finite Element Analysis

The finite element analysis (FEA) of the gearbox housing is required prior to solving the acoustic
radiation problem for the following reasons:

• The gearbox structure mesh generated in FEA is imported into Coustyx to build the model
to solve the acoustic problem.

• The structural response due to forces on the housing at each frequency in the frequency domain
is loaded into the Coustyx model. These values are used as the input velocity boundary
condition.

ANSYS is used to compute the frequency response of the gear box for the given excitation. The
FEA data is imported into Coustyx from the ANSYS results (*.rst) file.

2.1 FE Mesh Modeling

In the ANSYS FE model, SHELL63 elements are used to create the box surfaces. A concentrated
mass of 10 grams is attached to center of the top plate using MASS21 element, to account for the
mass of the stinger and the moving part of the shaker.
The FE model used for the structural analysis shown in Figure 2 has 970 nodes, 942 shell elements,
and 1 concentrated mass.



Figure 2: FE model of the GearBox.

The physical properties of the materials used in FEA analysis are given in Table 1.

Table 1: Physical properties of materials used in FEA.

Material Elastic Modulus, Pa Shear Modulus, Pa Poisson’s Ratio Density, kg/m3

Steel 2.034E+11 7.823E+10 0.3 7850
Aluminum 7.31E+10 2.748E+10 0.33 2700

2.2 Natural Frequencies and Normal Modes

The natural frequencies and mode shapes are extracted by solving the FE eigenvalue problem of
the gearbox housing. The eigenvectors are normalized with respect to the mass matrix to get the
structure normal modes. Since the top plate is relatively more flexible compared to the remaining
five surfaces, several free vibration mode shapes of the gearbox housing resemble classic plate modes
of the top surface. Mode 1 is a (1,1) mode of the top plate. Similarly Mode 2 is a (1,2) plate
mode, Mode 3 is a (2,1) plate mode, Mode 4 is a (2,2) plate mode and Mode 5 is a (1,3) plate mode
respectively. In a (m,n) plate mode m and n represent the number of half-wave lengths along the
x and y directions respectively.
Table 2 lists some of the natural frequencies of the gearbox housing. The first five modes are purely
classical modes of the top plate. For some of the higher modes, the side and the bottom surfaces of
the gearbox undergo deformation as well. Figure 3 shows the first five free vibration modes of the
gearbox housing.

2.3 Forced Response - Direct Formulation

Forced response analysis is performed using Direct formulation (or, Full Harmonic Analysis proce-
dure) in the frequency range of 114.75–1000 Hz.
A sinusoidal force of unit amplitude is applied at the center of the top plate (at node 854). The
radiation from the resulting housing vibration is computed in the frequency range 114.75–1000 Hz
with a frequency resolution of 14.75 Hz.
The results (*.rst) file contains the nodal displacements at each frequency. This data is loaded into
Coustyx model and is later applied as the velocity boundary condition to predict noise generated by
the gearbox housing in this frequency range.



Table 2: Gearbox natural frequencies from ANSYS.

Mode Number Frequency, Hz
1 157
2 329
3 366
4 505
5 543
6 647
7 741
8 760
9 789
10 797
11 829
12 907
13 936
14 962

3 Coustyx Noise Radiation Predictions

Coustyx model is created by importing the FE mesh. The frequency response data from the FEA
analysis is loaded into Coustyx and is applied as a structure velocity boundary condition on the
gearbox housing. The analysis parameters are then set and the acoustic analysis is run to compute
radiation predictions.

3.1 Problem Setup

Follow the steps to setup Coustyx model and perform acoustic analysis on the gearbox housing.
Open Coustyx from the start menu of your computer.

3.1.1 Create a New Model

• In the main menu select: File > New Model. The window in Figure 4 will then appear.

• Choose the model type: ‘Multidomain Model’ and select model units: meter-kilogram-second
(SI units). Note that the selection of model units is consistent with the unit of length in the
structure mesh. Click ‘OK’ to proceed.



(a) Mode 1: 157 Hz (b) Mode 2: 329 Hz

(c) Mode 3: 366 Hz (d) Mode 4: 505 Hz (e) Mode 5: 543 Hz

Figure 3: Surface normal velocity distribution for the first five free vibration modes.

Figure 4: New Model Selection Window.



Figure 5: Import a finite element structure mesh.

3.1.2 Import FE Structure Mesh

• In Coustyx model main menu select: Model > Structures.

• Right–click on Structures and select: Import > Ansys Results (.rst) Files (as shown in
Figure 5) to import mesh from Nastran bulk data format. The FE meshes from Abaqus and
Nastran bulk data formats can be imported by selecting Abaqus (.inp) File or Nastran
Bulk Data (.bdf) File... respectively.

• Select the appropriate FE structure data file to be imported from the browser and click ‘Open’.

3.1.3 Load Frequency Response Data

• In Coustyx model main menu select: Model > Structures > Structmesh 0 or <Struct
Mesh Name>.

• Right-click on Structmesh 0 or <Struct Mesh Name> and select: Load Freq Response
Data > Ansys rst File (as shown in Figure 6). The other valid data formats from which
frequency response data can be loaded into Coustyx are Nastran OP2 File and Nastran
Punch File....

• Select the appropriate frequency response data file to be loaded from the browser and click
‘Open’.

3.1.4 Generate BE Mesh

• Select: Model > Structures > Structmesh 0 or <Struct Mesh Name>.

• Right-click on Structmesh 0 or <Struct Mesh Name> and select: Open to view the struc-
ture mesh in the GUI. The structure mesh will appear as shown in Figure 7.

• Move the cursor into the GUI window with the structure mesh and observe the cursor change
to move-cursor style (or to the shape of ‘+’). To manipulate the view:

– Use the GUI control panel tools shown in Figure 8 to zoom and rotate the model.



Figure 6: Load frequency response data into Coustyx.



Figure 7: Structure mesh opened in Coustyx GUI.

Figure 8: Coustyx GUI control panel tools.



Figure 9: Select all displayed elements in the GUI.

– Hold down the left-click button and move the mouse to rotate the model in the GUI.

– Hold down the right-click button and move the mouse to move the model in the GUI.

– Move and rotate the model to see the holes on one of the side surfaces on the structure.

• Display element edges of the structure mesh.

– Move the cursor into the GUI window of the structure mesh.

– Press and hold the shift-key to observe the cursor change from move-cursor style (or ‘+’
shape) to an arrow style.

– Right-click on the mesh while holding down the shift-key to view a pop-up context menu
shown in Figure 9 and select: Select All Displayed Elements.

– Again right-click on the mesh while holding down the shift-key and select: Selected
Elements > Display Style to view a pop-up window shown in Figure 10.

– Pick the option Show Edges and click ‘OK’.

– To unselect all the elements right-click on the mesh again while holding down the shift-key
and select: Unselect All.

• Create seams at the hole edges to avoid skinning the interior surface of the gearbox housing.

– Select the tabbed window Skin from the series of tabs located below the structure mesh.

– Move the cursor to the structure mesh in GUI.

– Left-click on the elements around the edge of a hole while holding the shift-key. Make
sure to select elements with nodes on the hole edge as shown in Figure 11.

– Right-click on the mesh while holding down the shift-key to view the context menu and
select: Selected Elements > Display Connected Nodes as shown in Figure 12.

– Left-click on the displayed nodes while holding the shift-key to pick the nodes to be part
of the seam. Make sure to pick nodes in a specific direction.

– Pick the nodes until you see a circular seam following the edge of the hole as shown in
Figure 13.

– From the tabbed windows located below the structure mesh select: Skin > Accept
Seam.

• Create seams around all the four holes in the gearbox housing following the instructions given
above.



Figure 10: Element Display Style Window.

Figure 11: Select elements for creating a seam.



Figure 12: Display connected nodes for creating a seam.

Figure 13: Pick nodes to create a seam.



Figure 14: Edit material properties.

• Right-click on the mesh while holding down the shift-key and select: Unselect All to unselect
all elements.

• Skin the finite element structure mesh to generate a boundary element mesh for Coustyx.

– Left-click on any element on the exterior surface of the gearbox housing mesh while
holding the shift-key. Make sure you select only one element.

– From the tabbed windows located below the structure mesh select: Skin > Create Skin.

– Once the skin is created select: Skin > Create Mesh From Skin to generate a boundary
element mesh.

• To verify the creation of boundary element mesh, from the main model menu select: Model
> Direct BE Meshes > NewMeshCreatedFromSkin. Right-click on NewMeshCreat-
edFromSkin and select: Open to view the boundary element mesh created from skinning
the FE structure mesh.

3.1.5 Define Material Properties

• In the main model menu select: Model > Materials > Air. Right-click on Air and select
Edit.... Figure 14 will appear.

• Type-in the name of the material as ‘Air’.

• Define SpeedSound as a constant with value 343 m/s. The unit is consistent with the unit
of length (m) in the structure mesh.

• Define AmbientDensity as a constant with value 1.21 kg/m3. The unit is consistent with
the unit of length (m) in the structure mesh.

3.1.6 Fill Holes

• Open the Coustyx BE mesh from the main model menu by selecting: Model > Direct BE
Meshes > NewMeshCreatedFromSkin. Right-click on NewMeshCreatedFromSkin
and select: Open to view the boundary element mesh in the GUI.

• Select the tabbed window Fill Hole from the series of tabs located below the BE mesh.

• Follow the instructions given earlier in Section 3.1.4 to display element edges in the mesh.

• Left-click on the elements around the edge of a hole while holding the shift-key. Make sure to
select elements with nodes on the hole edge (similar to the Figure 9).



Figure 15: Fill hole using triangle elements.

• Right-click on the mesh while holding down the shift-key to view the context menu and select:
Selected Elements > Display Connected Nodes (similar to the Figure 12).

• Left-click on the displayed nodes while holding the shift-key to pick the nodes on the edge of
the hole in a specific direction.

• Pick the nodes until a unique closed loop is identified by the appearance of triangle elements
filling the hole as shown in Figure 15.

• The elements created to fill the holes are automatically added to a new set created with the
name ‘Hole 1’ in: Fill Hole > New Set Name.

• From the tabbed windows located below the structure mesh select: Fill Hole > Fill Hole.

• Repeat the above instructions to fill all the four holes in the gearbox housing.

3.1.7 Define Boundary Conditions

• Edit the existing default boundary condition.

– In the Coustyx main model menu select: Model > Boundary Conditions > Default.

– Right-click on Default and select: Edit... to make changes to the default boundary
conditions applied to all the boundary elements. The window in Figure 16 will appear.

– Type-in the new name ‘Structural Velocity BC’.

– Select Structure Velocity from the drop-down menu for ‘Type’. The window in Fig-
ure 17 will appear.

– Fill the Structure Name with Structmesh 0 or <Struct mesh name>. For the current
model there is no structure interface, so leave Structure Interface Name blank.

– Select ‘Choose Default Options’ as interpolation options for mismatched meshes.

– Click ‘OK’ to save the boundary condition.

• Create a new rigid boundary condition.

– In the main model menu select: Model > Boundary Conditions.

– Right-click on Boundary Conditions and select New....

– In the New Boundary Condition window type-in the new name ‘Rigid BC’.



Figure 16: Edit boundary conditions window.

Figure 17: Edit structure velocity boundary condition window.



Figure 18: Apply boundary conditions through selected elements.

– Select Uniform Normal Velocity from the drop-down menu for ‘Type’.

– Enter zero constant values for the real and imaginary values of the normal velocity.

– Click ‘OK’ to save the boundary condition.

3.1.8 Apply Boundary Conditions

The boundary conditions defined earlier are applied to the elements in the Coustyx BE mesh before
running acoustic analysis.

• Apply structure velocity boundary condition to all the elements in the Coustyx BE model.

– Select: Model > Direct BE Meshes > NewMeshCreatedFromSkin. Right-click
on NewMeshCreatedFromSkin and select Open to view the boundary element mesh
in the GUI.

– Right-click on the mesh while holding down the shift-key to view the context menu and
select: Select All Displayed Elements.

– Again right-click on the mesh while holding down the shift-key and select: Selected
Elements > Set Boundary Condition > Structure Velocity BC (as shown in
Figure 18). If the boundary condition Structure Velocity BC is inactive, it implies
that it has already been applied over the selected elements.

• Apply rigid boundary conditions on all the elements created to fill holes. Note that we don’t
have structure velocities for these as they are newly created in Coustyx and not present in the
original structure. Since the elements filling the holes are conveniently added to sets named
‘Hole 1’, ‘Hole 2’ and so on, we can apply the boundary conditions on them through these
sets.

– In the main model menu select: Model > Direct BE Meshes > NewMeshCreated-
FromSkin> Sets > Holes 1.

– Right-click on Holes 1 and select: Elements > Set Boundary Condition > Rigid
BC as shown in Figure 19.

– Repeat the above for other holes as well.



Figure 19: Apply boundary conditions through sets.



Figure 20: Specifying boundedness of the domain.

3.1.9 Domains

• Specify the type of acoustic problem by selecting: Model > Domains > Domain1 or
<Domain Name> > Boundedness. The radiation from a gearbox housing is an exterior
or unbounded acoustic problem. Right-click on Boundedness and select: Boundedness >
Unbounded as shown in Figure 20.

• Choose the fluid medium around the gearbox housing by selecting: Model > Domains >
Domain1 or <Domain Name> > Material. Right-click on Material and select: Material
> Air.

• To set ‘the side of the mesh on which the domain is’ you need to first check the direction of
mesh normals.

– Open Coustyx BE mesh in the GUI. Select: Model > Direct BE Meshes > NewMesh-
esCreatedFromSkin and right-click on NewMeshesCreatedFromSkin and select
Open.

– Move the cursor to the BE mesh in GUI.

– Right-click on the mesh while holding down the shift-key to view the context menu and
select: Select All Displayed Elements.

– From the tabbed windows located below the mesh select: Element Orientation to view
the direction of element normals (refer to Figure 21). The green arrow indicates the
positive direction and the red arrow indicates the negative direction of the normal. Here,
all the element normals are coming out of the mesh. By definition the positive side of the
mesh is defined as the side with positive element normals.

– Since we are interested in the radiation problem the domain is on the positive side of the
mesh.

• Select: Model > Domains > Domain1 or <Domain Name> > Direct BE Meshes >
NewMeshesCreatedFromSkin > Side of Mesh on which Domain is. Right-click on
Side of Mesh on which Domain is and select: Side of Mesh on which Domain is >
Positive as shown in Figure 22.



Figure 21: Element orientations.



Figure 22: Set the side of the mesh on which the domain is.



3.2 Run Acoustic Analysis

Coustyx analysis parameters are set in ‘Analysis Sequences’, which are then ‘Run’ to solve the
acoustics radiation problem.

• Select: Model > Analysis Sequences and right-click to create a new analysis sequence by
selecting New....

• Select Solver Controls tab to set solver parameters. Refer to Figure 23.

– Ensure the default solver options are satisfactory.

– Set Initial Guess > Previous Solution from the drop-down menu.

• Move onto Frequency Ranges tab to specify analysis frequencies. Refer to Figure 24.

– Enter the starting frequency to be 114.75 Hz in the table under ‘Start (Hz)’.

– Enter a value of 14.75 Hz for the frequency resolution under ‘Delta (Hz)’.

– Enter the final frequency to be 1000 Hz in the table under ‘End (Hz)’.

• Now move onto Outputs tab where output file names are specified. Ensure the default settings
in Outputs tab are satisfactory.

• Click ‘OK’ to save the new analysis sequence.

• To edit the analysis parameters any time, select: Model > Analysis Sequences > Analysis
Sequence. Right-click and select Edit.

• To start acoustic analysis, select: Model > Analysis Sequences > Analysis Sequence.
Right-click and select Run to perform acoustic analysis on the gearbox housing with the
applied vibrations for the desired frequencies.

3.3 Post-processing/Outputs

Coustyx creates the following output files based on the choices made in Outputs tab in Analysis
Sequence.

3.3.1 results.dat

A binary results file is saved by Coustyx for later use. When the model is re-run Coustyx directly
uses these results if the checksum of the model matches with the checksum in the results file. This
file can’t be interpreted by the user and is only for Coustyx use.

3.3.2 sensors.dat

The pressure and particle velocity at the sensor locations are written into this ASCII-text file. Since
we didn’t add any sensors to the gearbox housing radiation problem, this file is empty.

3.3.3 power.dat

Coustyx automatically creates an ASCII data file entitled power.dat during analysis. This file con-
tains acoustic sound power values computed at each analysis frequency. It has five columns. The
first column contains analysis frequencies in the units ‘Hertz’. The second and third columns con-
tain the radiated (active) sound power and the reactive sound power respectively. The input power
is in the fourth column with the same unit. The units of power are consistent with the material
properties - sound speed, and ambient density, defined earlier; here the unit is ‘Watt’. The final
column consists of the radiation efficiency.
The radiated sound power is plotted against the analysis frequency in Figure 25 using matlab plot
command. The sound power radiated (Figure 25) has peaks corresponding to the structural vibration
modes that have a non-zero net volume velocity.



Figure 23: Analysis solver controls.



Figure 24: Set analysis frequencies.
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Figure 25: Sound power from the forced vibration response.

3.3.4 iglass.igl

IGlass files are post-processing data files created by Coustyx to visualize the acoustic analysis results.
Refer to Figure 26.

• Double-click on ‘iglass.igl’ file to open it.

• Click on the Attribs tab on the top-left of the iglass viewer.

• Select: Attribs > Attribute > Pressure to view the pressure distribution on the surface of
the gearbox housing.

• Click on the View tab on the top-left of the iglass viewer.

• Press the slider under View > Phase, to start animation. This activates the animation of
the wave propagation on the housing surface.

• To view the results for different frequencies press the slider under View > Frequency.



Figure 26: IGlass viewer showing sound pressure distribution at 760 Hz.
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